Migrando para o SDK mais recente

Atualizando para o SDK mais recente

Migrando para o SDK do diretório de aplicativos da Hootsuite

É recomendável atualizar seus aplicativos para a nova função. Para atualizar para a versão 2.0, basta atualizar a versão do arquivo da Biblioteca JS para o qual o aplicativo está apontando.

Atualize o arquivo de: https://d2l6uygi1pgnys.cloudfront.net/jsapi/0-6/hsp.js para: https://d2l6uygi1pgnys.cloudfront.net/jsapi/2-0/hsp.js

Quando você atualizar seus aplicativos para a nova função, nenhum outro método precisará ser atualizado. Depois da atualização, você poderá remover os receptores de aplicativo do seu aplicativo. 

Se o seu aplicativo tiver um plugin ou usar os métodos sendtoapp, sendprofiletoapp ou sendcomposedmsgtoapp, recomendamos que você atualize para o novo arquivo, já que isso resolverá o problema de plugins que nem sempre são carregados no painel Hootsuite. Daqui para frente, todas as versões e melhorias futuras serão adaptadas para a versão atual do SDK. 

Se você estiver atualizando um aplicativo baseado em fluxo da versão 0.5 para a 2.0, observe que o modelo de fluxo foi significativamente atualizado e que talvez seja preciso fazer ajustes em seu css para que seu aplicativo seja exibido corretamente no painel. 

Versões anteriores

Para aplicativos ainda em execução no SDK v0.6 do Diretório de Aplicativos da Hootsuite, você tem acesso à documentação aqui: